OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

osgPPU with CompositeViewer


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> osgPPU [osgPPU]
View previous topic :: View next topic  
Author Message
Samppa2005
Newbie


Joined: 12 Apr 2011
Posts: 6

PostPosted: Tue Apr 19, 2011 12:34 pm    Post subject:
osgPPU with CompositeViewer
Reply with quote

Hi,

Has anyone been trying to use the osgPPU with CompositeViewer? I tried to run the same code i succesfully use with a regular viewer but it fails when i try to apply it to the second view. First view works fine but the second fails. Basically i'm just applying the processor to the view camera instead of the viewer camera. I would just like to know if someone has used it succesfully to make sure the problem is in my code Smile
I am using the 0.4.0 version of osgPPU.

Thank you!

Cheers,
Sami
Back to top
View user's profile Send private message
Samppa2005
Newbie


Joined: 12 Apr 2011
Posts: 6

PostPosted: Wed Apr 27, 2011 8:59 am    Post subject:
Reply with quote

Hi,

Nobody tried this?

I made the simplest possible test i could think of and just set one UnitOut to the processor so there would be no actual action from the processor other then relaying the image forward. I set the processor with the view camera of the first view and it works fine. When i set it up with the second view camera it results only in a black screen. The viewport size and position seem correct but something goes wrong and i'm running out of ideas what it could be. Any good ideas?


Thank you!

Cheers,
Sami
Back to top
View user's profile Send private message
danoo
Appreciator


Joined: 16 Dec 2011
Posts: 146

PostPosted: Mon Nov 05, 2012 8:07 am    Post subject:
osgPPU with CompositeViewer
Reply with quote

Hello all

I bring this subject again to the surface. And I wonder if Art (or anybody else out there) has an opinion about this he would like to share...

In a composite viewer setting, views can be dynamically added and removed. In osgPPU, the Processor is part of the scene graph, but it has to be connected to a views camera...

So there are two problems which are not solved:
- How to disconnect a view (camera) from the processor and succesfully reconnect a new view to it?
- How to deal with multiple views visible at the same time? Multiple processors added to the scene graph?

I guess for the last point, there is a conceptional problem. The whole postprocessing should ONLY be bound to the view and leave no traces in the scene graph itself...

What do you think?
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> osgPPU [osgPPU] All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts compositeviewer, close and remove view Meldryt General 0 Wed Dec 14, 2016 2:01 pm View latest post
No new posts CompositeViewer and FBO minghia General 1 Tue Jul 26, 2016 3:43 am View latest post
No new posts CompositeViewer and osgViewer::Screen... Tedzini General 0 Mon Jul 11, 2016 11:23 pm View latest post
No new posts compositeviewer with mutliple windowm... Meldryt General 1 Wed Apr 27, 2016 7:45 am View latest post
No new posts CompositeViewer Node render order pro... Tedzini General 0 Sat Feb 27, 2016 12:41 am View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP