OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

Is the VPB 1.0.0 available?

Goto page Previous  1, 2
 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> VirtualPlanetBuilder [vpb]
View previous topic :: View next topic  
Author Message
creature (Ethan Fahy)
Appreciator


Joined: 07 Sep 2011
Posts: 142

PostPosted: Thu Sep 08, 2011 9:16 pm    Post subject:
Re: Is the VPB 1.0.0 available?
Reply with quote

You mention that there are VPB 3rd part dependencies; is this a download package that I missed? I don't see any reference to it on the VPB website or in the VPB source code...
Back to top
View user's profile Send private message
Chris 'Xenon' Hanson
Guest





PostPosted: Thu Sep 08, 2011 9:20 pm    Post subject:
Is the VPB 1.0.0 available?
Reply with quote

On 9/8/2011 3:16 PM, Ethan Fahy wrote:
Quote:
You mention that there are VPB 3rd part dependencies; is this a download package that I missed? I don't see any reference to it on the VPB website or in the VPB source code...

I mean, just GDAL and such.

You're really posting very vague responses. If you're having trouble with missing DLLs,
you have to say what DLLs those are, or nobody is going to be able to help you.

--
Chris 'Xenon' Hanson, omo sanza lettere. http://www.alphapixel.com/
Digital Imaging. OpenGL. Scene Graphs. GIS. GPS. Training. Consulting. Contracting.
"There is no Truth. There is only Perception. To Perceive is to Exist." - Xen


------------------
Post generated by Mail2Forum
Back to top
Brad Christiansen
User


Joined: 04 Nov 2010
Posts: 91

PostPosted: Fri Sep 09, 2011 4:46 am    Post subject:
Is the VPB 1.0.0 available?
Reply with quote

Hi,

To run VPB you need in your path: the osg dlls, vpb.dll, gdals dll. I am responsible for the 3rd party library collection you are using and can confirm that this includes all you need to compile and run VPB and OSG from source, using the latest version (atleast as of a few weeks ago when I last did a full build).

Cheers,
Brad

-----Original Message-----
From: [mailto:] On Behalf Of Ethan Fahy
Sent: Friday, 9 September 2011 5:16 AM
To:
Subject: Re: [vpb] Is the VPB 1.0.0 available?

You mention that there are VPB 3rd part dependencies; is this a download package that I missed? I don't see any reference to it on the VPB website or in the VPB source code...

------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=42550#42550








-------------------------------------------------------------------------
DISCLAIMER: This e-mail transmission and any documents, files and
previous e-mail messages attached to it are private and confidential.
They may contain proprietary or copyright material or information that
is subject to legal professional privilege. They are for the use of
the intended recipient only. Any unauthorised viewing, use, disclosure,
copying, alteration, storage or distribution of, or reliance on, this
message is strictly prohibited. No part may be reproduced, adapted or
transmitted without the written permission of the owner. If you have
received this transmission in error, or are not an authorised recipient,
please immediately notify the sender by return email, delete this
message and all copies from your e-mail system, and destroy any printed
copies. Receipt by anyone other than the intended recipient should not
be deemed a waiver of any privilege or protection. Thales Australia
does not warrant or represent that this e-mail or any documents, files
and previous e-mail messages attached are error or virus free.

-------------------------------------------------------------------------



------------------
Post generated by Mail2Forum
Back to top
View user's profile Send private message
Mattias Helsing
Guest





PostPosted: Fri Sep 09, 2011 11:56 am    Post subject:
Is the VPB 1.0.0 available?
Reply with quote

Hi all

The previous post had a CMake snippet that was bad. Here's one that
actually works:

# with visual studio 2010 we get multiply defined symbols
if(MSVC)
if(${MSVC_VERSION} STREQUAL "1600")
message("Visual Studio 2010 (${MSVC_VERSION}) build fix at play
(/FORCE:MULTIPLE)")
set(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS}
/FORCE:MULTIPLE")
endif()
endif()


sorry
Mattias

On Wed, Sep 7, 2011 at 9:51 PM, Mattias Helsing <> wrote:
Quote:
Hello Ethan

I wonder if you have hit a problem reported earlier. see:

http://lists.openscenegraph.org/pipermail/osg-users-openscenegraph.org/2010-August/044528.html

It is reported as a bug in msvc, and I haven't tracked it for a while.
Try and set /FORCE:MULTIPLE in the linker param section for the vpd
library

A more long lasting solution is to set this in a CMakeLists.txt:
if(MSVC)
 if(${MSVC_VERSION} STREQUAL 1600)
   message("msvc2010 build fix /FORCE:MULTIPLE")
   set(CMAKE_SHARED_LINKER_FLAGS ${CMAKE_SHARED_LINKER_FLAGS} /FORCE:MULTIPLE)
 endif()
endif()

I don't have the sp1 for my msvc2010 so I don't know if it fixes this issue

cheers
Mattias

On Wed, Sep 7, 2011 at 8:56 PM, Ethan Fahy <> wrote:
Quote:
I am using the following:
OSG debug from here:
http://openscenegraph.alphapixel.com/sites/default/files/osgdownload/3.0.0/OpenSceneGraph-3.0.0-VS10.0.30319-x86-debug-12681.7z
OSG release from here:
http://openscenegraph.alphapixel.com/sites/default/files/osgdownload/3.0.0/OpenSceneGraph-3.0.0-VS10.0.30319-x86-release-12681.7z
OSG 3ryparty from here:
http://members.iinet.net.au/~bchrist/3rdParty_VC10_x86_x64.zip

I am on Windows 7 Pro 32-bit.  CMake version 2.8.5.  Visual Studio 2010 w/ all latest updates.

------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=42505#42505










------------------
Post generated by Mail2Forum
Back to top
creature (Ethan Fahy)
Appreciator


Joined: 07 Sep 2011
Posts: 142

PostPosted: Fri Sep 09, 2011 12:36 pm    Post subject:
Success!
Reply with quote

Set my paths correctly and made the CMake mod that Mattias mentioned and presto! everything's working like a charm. My sincere thanks to everyone for their assistance, really saved my bacon!
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> VirtualPlanetBuilder [vpb] All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum



Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP