OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

Compiling VPB/GDAL on Win7 with VS2010


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> VirtualPlanetBuilder [vpb]
View previous topic :: View next topic  
Author Message
Jona
Newbie


Joined: 20 Aug 2011
Posts: 11

PostPosted: Tue Sep 13, 2011 1:25 pm    Post subject:
Compiling VPB/GDAL on Win7 with VS2010
Reply with quote

Hi,
I'm trying to compile VirtualPlanetBuilder with VisualStudio 10. I used cmake to generate the project files and everything looks good, but I get the following linker errors:

"1>gdal.lib(gdalrasterblock.obj) : error LNK2038: Konflikt ermittelt für "_ITERATOR_DEBUG_LEVEL": Der Wert "0" stimmt nicht mit dem Wert "2" in BuildLog.obj überein."
(the Iterator_Debug_Level is not the same in gdal.lib and my project).

I used the precompiled Debug build of OpenSceneGraph and i'm also trying to create a debug build of vpb.
At first I tried a precompiled build of gdal, from gisinternals, but it seams, that they are only release builds, so i can't use them for my debug build.

So the next thing was, that i downloaded the gdal source and tried to compile it by myself. There where this nmake makefile-VSProjects, where VS apparently only invokes the makefile for gdal. This builds without any problems, but it seams to be still a release build, at least it get the same Iterator_Debug_Level error message.
The strange thing is, that you can select between release and debug in the gdal VS10 Project, but it doesn't seam to change anything. The help says, I can configure everything in the nmake.opt in which i find examples for invoking the build, like "# nmake -f makefile.vc MSVC_VER=1500 DEBUG=1" which sounds promising. I checked the project settings and it gets called with DEBUG=1 in the debug configuration but it doesn't change anything Sad

To sum up: I want to use a debug build of VPB which I seam to have to compile by myself, for which I need a debug build of GDAL, which I'm not able to compile Sad Any help will be appreciated!

Thank you!

Cheers,
Jonathan
Back to top
View user's profile Send private message
creature (Ethan Fahy)
Appreciator


Joined: 07 Sep 2011
Posts: 142

PostPosted: Tue Sep 13, 2011 6:49 pm    Post subject:
Reply with quote

I was basically in the same boat as you several days ago and was able to get VPB built in Visual Studio 2010 thanks to some awesome help from this forum. I'll try to reciprocate if I can. I had success compiling VPB by downloading OSGeo4W and having it retrieve all GDAL precompiled binaries for me. You can track how I got VPB built by following this thread:
http://forum.openscenegraph.org/viewtopic.php?t=8806
after the part where I threadjack it Laughing
Back to top
View user's profile Send private message
Jona
Newbie


Joined: 20 Aug 2011
Posts: 11

PostPosted: Wed Sep 14, 2011 6:43 pm    Post subject:
Reply with quote

Well thanks. I thought that I need a debug build of VPB because I just hat OSGB Debug binaries in use. But than i realized, that i just need vpb to create the files and don't want to debug anything there, so i made a release build, where i had at first the same linker error as you, but thanks to that thread i could fix it.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> VirtualPlanetBuilder [vpb] All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts Compiling vertext shader fails on Intel loopy General 7 Fri Dec 14, 2018 7:28 pm View latest post
No new posts issues compiling 3.0.1 Lonnie.CTR.Souder General 2 Wed Sep 26, 2018 8:59 pm View latest post
No new posts Problem compiling OSG 3.4.1 osgDB 64 bit tonyor Build system [build] 0 Thu Sep 21, 2017 12:41 am View latest post
No new posts GDAL plugin hroch Plugins [osgPlugins] 0 Thu May 26, 2016 8:31 am View latest post
No new posts GraphicsWindowWin32 compiling errors ... Davide Raccagni Submission 4 Thu May 19, 2016 11:32 am View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP