OpenSceneGraph Forum Forum Index OpenSceneGraph Forum
Official forum which mirrors the existent OSG mailing lists. Messages posted here are forwarded to the mailing list and vice versa.
 
   FAQFAQ    SearchSearch    MemberlistMemberlist    RulesRules    UsergroupsUsergroups    RegisterRegister 
 Mail2Forum SettingsMail2Forum Settings  ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
   AlbumAlbum  OpenSceneGraph IRC ChatOpenSceneGraph IRC Chat   SmartFeedSmartFeed 

Building VPB


 
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> VirtualPlanetBuilder [vpb]
View previous topic :: View next topic  
Author Message
kevin
Newbie


Joined: 17 Nov 2011
Posts: 2

PostPosted: Thu Nov 17, 2011 4:26 am    Post subject:
Building VPB
Reply with quote

Hi,

I'm having trouble compiling VPB on VS10, see the compile error below.

I tried both the latest svn and the latest tagged version (0.9.12) and both give the same result. I'm building against OSG 3.0.1 and gdal 1.8.1, which both compiled just fine.

Any ideas? I've read this issue can come up if you mix static and shared libs, but changing my OSG and VPB build to one or the other does not seem to matter.

Code:

1>------ Build started: Project: ZERO_CHECK, Configuration: Release Win32 ------
2>------ Build started: Project: vpb, Configuration: Release Win32 ------
3>------ Skipped Build: Project: uninstall, Configuration: Release Win32 ------
3>Project not selected to build for this solution configuration
2>osgDB.lib(osg80-osgDB.dll) : error LNK2005: "public: void __thiscall std::basic_ofstream<char,struct std::char_traits<char> >::`vbase destructor'(void)" (??_D?$basic_ofstream@DU?$char_traits@D@std@@@std@@QAEXXZ) already defined in SpatialProperties.obj
2>     Creating library C:/Workspace/VirtualPlanetBuilder/trunkVirtualPlanetBuilder/build/lib/Release/vpb.lib and object C:/Workspace/VirtualPlanetBuilder/trunkVirtualPlanetBuilder/build/lib/Release/vpb.exp
2>C:\Workspace\VirtualPlanetBuilder\trunkVirtualPlanetBuilder\build\lib\Release\vpb.dll : fatal error LNK1169: one or more multiply defined symbols found
4>------ Build started: Project: Applications vpbsizes, Configuration: Release Win32 ------
5>------ Build started: Project: Applications vpbmaster, Configuration: Release Win32 ------
6>------ Build started: Project: Applications osgdem, Configuration: Release Win32 ------
7>------ Build started: Project: Applications vpbcache, Configuration: Release Win32 ------
5>     Creating library C:/Workspace/VirtualPlanetBuilder/trunkVirtualPlanetBuilder/build/bin/Release/vpbmaster.lib and object C:/Workspace/VirtualPlanetBuilder/trunkVirtualPlanetBuilder/build/bin/Release/vpbmaster.exp
5>  application_vpbmaster.vcxproj -> C:\Workspace\VirtualPlanetBuilder\trunkVirtualPlanetBuilder\build\bin\Release\vpbmaster.exe
6>     Creating library C:/Workspace/VirtualPlanetBuilder/trunkVirtualPlanetBuilder/build/bin/Release/osgdem.lib and object C:/Workspace/VirtualPlanetBuilder/trunkVirtualPlanetBuilder/build/bin/Release/osgdem.exp
6>  application_osgdem.vcxproj -> C:\Workspace\VirtualPlanetBuilder\trunkVirtualPlanetBuilder\build\bin\Release\osgdem.exe
7>     Creating library C:/Workspace/VirtualPlanetBuilder/trunkVirtualPlanetBuilder/build/bin/Release/vpbcache.lib and object C:/Workspace/VirtualPlanetBuilder/trunkVirtualPlanetBuilder/build/bin/Release/vpbcache.exp
7>  application_vpbcache.vcxproj -> C:\Workspace\VirtualPlanetBuilder\trunkVirtualPlanetBuilder\build\bin\Release\vpbcache.exe
8>------ Build started: Project: ALL_BUILD, Configuration: Release Win32 ------
8>  Build all projects
9>------ Skipped Build: Project: INSTALL, Configuration: Release Win32 ------
9>Project not selected to build for this solution configuration
========== Build: 6 succeeded, 1 failed, 0 up-to-date, 2 skipped ==========




Thanks !

Kevin
Back to top
View user's profile Send private message
kevin
Newbie


Joined: 17 Nov 2011
Posts: 2

PostPosted: Sat Nov 19, 2011 4:06 am    Post subject:
Reply with quote

I'll answer my own post - found the fix in another post, ( being only my second post, I'm unable to put a link here...)

I can now generate nice terrain easily !
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OpenSceneGraph Forum Forum Index -> VirtualPlanetBuilder [vpb] All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Similar Topics
Topic Author Forum Replies Posted
No new posts Building on macOS 10.14 Ulrich Hertlein General 9 Sun Nov 11, 2018 12:45 pm View latest post
No new posts building the fbx plugin Tare Plugins [osgPlugins] 2 Wed Oct 10, 2018 3:04 pm View latest post
No new posts Missing OpenThreads PDB when building... guyv Build system [build] 0 Thu Jul 12, 2018 12:39 pm View latest post
No new posts Building OpenSceneGraph-3.6.0 on Wind... ravidavi Build system [build] 7 Thu Apr 19, 2018 4:44 pm View latest post
No new posts Building OpenSceneGraph Windows Skaldi Build system [build] 3 Sun Dec 24, 2017 4:13 am View latest post


Board Security Anti Bot Question MOD - phpBB MOD against Spam Bots
Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP